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1 Introduction
VICE (Versatile Commodore Emulator) is an open-source emulator for Commodore 8-bit com-
puters. On macOS it allows you to run authentic Commodore 64 (C64) software and to experi-
ment with a virtual C64 even if you do not own the original hardware. VICE emulates the C64,
C64DTV, C128, VIC-20, PET, Plus/4, and CBM-II series with high accuracy.

This manual focuses on:

• installing VICE on modern macOS systems (Intel and Apple Silicon),

• configuring the C64 emulator variant (x64sc) for comfortable use,

• loading and running software (disk, tape, cartridge, and PRG files),

• basic joystick, keyboard, and performance settings,

• taking snapshots, using the built-in monitor, and troubleshooting.

The compiled PDF of this manual is available at https://hilpisch.com/vice.pdf.

2 System Requirements
2.1 Minimum and Recommended Requirements
Before installing VICE it is useful to check that your Mac meets basic requirements and, if
possible, slightly exceeds them for smoother emulation.

• macOS 12.0 (Monterey) or later for Intel and Apple Silicon Macs,

• at least 100 MB of disk space for the emulator itself,

• an internet connection for initial download.

For the best experience:

• use a recent macOS release (for example Sonoma or later),

• prefer an Apple Silicon Mac for optimal performance,

• consider a USB game controller if you plan to play games extensively.

3 Installing VICE on macOS
3.1 Method 1: Official Download (Recommended)
This path uses the official binaries maintained by the VICE project and is appropriate for most
users who prefer a graphical workflow.

Step 1: Download VICE. Visit the official VICE site at https://vice-emu.sourceforge.
io and download the macOS package that matches your hardware:

• Apple Silicon Macs (M1, M2, M3, M4): choose the GTK3 build labelled for Apple Silicon
and macOS 12+.

• Intel Macs: choose the GTK3 build labelled for Intel and macOS 12+.

The GTK3 variants integrate better with macOS than SDL-only builds.
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Step 2: Install the application.

• Locate the downloaded .dmg or .zip in your Downloads folder.

• Double-click to mount or extract it.

• Drag the resulting VICE folder into your Applications folder.

Step 3: Bypass macOS Gatekeeper on first launch. Because VICE is not notarised
with an Apple Developer certificate, macOS may initially block it.

• Attempt to open the application once; macOS will display a warning.

• Open System Settings → Privacy & Security and look for a message about VICE being
blocked.

• Click Open Anyway, or right-click the app in Finder and choose Open.

Advanced users who understand the security implications can relax Gatekeeper more broadly
using tools such as spctl and xattr, but this manual assumes the standard workflow.

Step 4: Launch the C64 emulator. Once installed:

• open the VICE folder in Applications,

• open its bin subfolder,

• launch x64sc for the cycle-accurate C64 emulator.

Other executables emulate different Commodore models (such as xvic for the VIC-20 or x128
for the C128), but x64sc is the main focus for the C64 workbook.

3.2 Method 2: Homebrew Installation
If you already use the Homebrew package manager and are comfortable with Terminal com-
mands, you can install and update VICE like any other package.

• ensure Homebrew is installed (see https://brew.sh),

• run brew install vice in a Terminal,

• start the C64 emulator with x64sc.

Homebrew handles dependencies and places the binaries on your PATH, which can be convenient
if you prefer Terminal workflows.

4 Initial Configuration
4.1 Selecting the Machine Model
After launching x64sc, choose a suitable C64 model:

• open Settings → Model Settings → Machine Model,

• pick C64 PAL (50 Hz) for most European software, or C64 NTSC (60 Hz) for many North
American releases,

• variants such as C64C use slightly different chip revisions but behave similarly for most
purposes.

3

https://brew.sh


4.2 Keyboard Mapping
VICE offers two keyboard modes:

• Symbolic mapping (recommended): keys produce the same characters as on your Mac
keyboard; quotation marks use the standard " key.

• Positional mapping: keys mimic the original C64’s physical layout; more authentic but
requires learning the old positions.

To adjust this:

• open Settings → Keyboard Settings,

• select Symbolic or Positional mapping as desired.

4.3 ROMs and Built-in Components
The C64 needs three ROMs:

• the KERNAL ROM (system routines),

• the BASIC ROM (interpreter),

• the character ROM (font data).

Standard VICE distributions ship with suitable ROM images, so you can start without extra
configuration. If you later install alternative ROMs (for example JiffyDOS), configure their
locations via Settings → Machine Settings → ROM Settings.

5 Loading and Running Software
5.1 Common File Formats
Before loading programs, it helps to know which file types you are looking at and how VICE
interprets them. VICE understands several C64 file formats:

• disk images: .d64, .g64,

• tape images: .t64, .tap,

• program files: .prg, .p00,

• cartridge images: .crt.

5.2 Smart Attach and Autostart
Smart Attach.

• Use File → Smart Attach Disk/Tape/Cartridge.

• Select your image; VICE detects the type and attaches it automatically.

Autostart.

• Use File → Autostart Disk/Tape Image.

• Choose a .d64, .t64, or .tap file.

• The emulator loads and runs the first program on the medium.
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5.3 Traditional Disk and Tape Loading
If you prefer to mimic the traditional C64 workflow, or when automatic methods fail, you can
load disks and tapes manually.

Disk loading.

• Attach a disk image via File → Attach Disk Image → Drive 8.

• At the C64 prompt, list the directory:

LOAD"$",8
LIST

• Load a specific program:

LOAD"PROGRAMNAME",8
RUN

• Shortcut for the first program:

LOAD"*",8,1
RUN

Tape loading.

• Attach a tape image via File → Attach Tape Image.

• At the prompt, type:

LOAD

• When prompted to “PRESS PLAY ON TAPE”, use the Datasette menu to press play.

6 Joystick and Controller Setup
6.1 Joystick Ports and Keyboard Joystick
The C64 has two logical joystick ports; most games use port 2 by default. In VICE, the simplest
default is to emulate a joystick on the keyboard and treat physical controllers as optional extras.

• Open Settings → Joystick Settings.

• Assign Joystick #2 to a keyset (for example Keyset A).

• Configure the keyset with your preferred keys for directions and fire.
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6.2 Using USB Controllers
In addition to keyboard emulation, you can map real USB gamepads or joysticks to the C64
joystick ports.

• Connect your USB controller before launching VICE.

• In Settings → Input Devices → Joystick, select the controller for Joystick 1 or Joystick 2.

• Use the Swap Joysticks command or Alt+J / Meta+J if a game expects input on the other
port.

7 Essential Shortcuts and Warp Mode
7.1 Core Hotkeys
On macOS, VICE assigns many actions to combinations with Alt or Meta:

• Alt+W: toggle Warp Mode (run as fast as possible),

• Alt+D: toggle fullscreen,

• Alt+P: pause/resume emulation,

• Alt+R: soft reset,

• Alt+Shift+R: hard reset,

• Alt+Q: quit.

7.2 Warp Mode
Warp Mode removes speed limits and is particularly useful when:

• fast-forwarding through long loading sequences,

• skipping ahead in demos or intros.
Toggle it on and off with Alt+W or via Settings → Warp Mode. Be aware that sound output
may be degraded or disabled in Warp Mode to maximise speed.

8 Snapshots, Audio, and Video
8.1 Saving and Restoring Snapshots
Snapshots let you freeze the entire emulator state and resume later, which is especially handy
when experimenting with low-level code or games that are hard to reach.

• Use Snapshot → Save Snapshot Image to save a .vsf file capturing the entire emulator
state.

• Later, Snapshot → Load Snapshot Image restores that exact state.

• Configure preferred snapshot directories in the Snapshot menu.

8.2 Audio Settings
Sound settings control both audio quality and CPU load.

• Adjust Settings → Sound Settings for sample rate and buffer size.

• Choose a SID emulation engine in Settings → SID Settings (for example FastSID vs ReSID)
depending on your CPU budget and accuracy needs.
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8.3 Video Settings
Video settings determine how the C64 screen is scaled and rendered on your Mac display.

• Use Settings → Video Settings to control scaling, aspect ratio, and PAL emulation.

• Toggle fullscreen with Alt+D or via the same menu.

9 Drive Emulation and Cartridges
9.1 True Drive Emulation

• True Drive Emulation simulates the original 1541 drive more faithfully, improving com-
patibility with some copy-protected or timing-sensitive software.

• Enable it in Settings → Drive Settings when you encounter loading issues.

9.2 Cartridge Images
• Attach cartridge files (.crt) via File → Attach Cartridge Image.

• Detach cartridges via the same menu when returning to disk- or tape-based software.

10 The Built-in Monitor
VICE includes a machine-language monitor for debugging and exploring low-level behaviour.

• Activate it via Machine → Activate Monitor.

• Use commands like r (registers), d (disassemble), m (memory), and break (set break-
points).

• exit or x returns to normal emulation.

The monitor is especially useful when following along with assembly examples in the C64 work-
book and in Chapter ?? of the main book.

11 Configuration Files and Troubleshooting
11.1 Configuration Files

• On macOS, VICE typically stores settings in /̃.config/vice/vicerc or (for older ver-
sions) /̃.vicerc.

• Use Settings → Save Settings or Save Settings on Exit to persist your configuration.

11.2 Common Issues and Fixes
• Application blocked: use the Open Anyway option in macOS Privacy & Security settings,

or right-click and choose Open.

• No sound: check sound settings, disable Warp Mode, and ensure the correct audio device
is selected.

• Games do not load: try different loading methods, switch PAL/NTSC model, or enable
True Drive Emulation.

• Joystick or controller issues: confirm device selection, swap joystick ports, or fall back to
keyboard keysets.
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• Keyboard mapping oddities: verify symbolic vs positional mode and disable conflicting
macOS shortcuts if needed.

12 Where to Find Software and More Information
12.1 Finding C64 Software

• Look for legal sources offering freeware or public-domain titles, and only download software
you are entitled to use.

• Modern homebrew sites and curated archives often provide ready-to-run disk images.

12.2 Official Documentation and Communities
• Official VICE documentation: https://vice-emu.sourceforge.io/vice_toc.html.

• Community forums and chat: long-running C64 communities and VICE-specific channels
provide up-to-date tips and troubleshooting help.

13 Quick Reference Card
Task Action
Start C64 emulator Launch x64sc
Load and run first program from disk Attach image, then LOAD"*",8,1 and RUN
Toggle Warp Mode Alt+W
Toggle fullscreen Alt+D
Reset Alt+R (soft), Alt+Shift+R (hard)
Swap joysticks Alt+J
Save snapshot Snapshot → Save Snapshot Image
Open monitor Machine → Activate Monitor
Quit Alt+Q

References
This manual condenses information from the official VICE documentation and several commu-
nity resources:

• Official VICE project site and manual: https://vice-emu.sourceforge.io

• VICE macOS notes and release news for version 3.9

• Homebrew formula details for vice at https://formulae.brew.sh/formula/vice

• Community guides and discussions on platforms such as Lemon64, RetroPie, and Reddit’s
/r/c64 and /r/retrocomputing, which document practical tips for macOS users.

For the most current and detailed information, always cross-check with the latest official VICE
documentation and release notes.
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